Issue with vimla.se
Incident Report for Vimla
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 08:37 CET
Investigating
We are currently investigating this issue.
Posted Feb 15, 2021 - 08:20 CET
This incident affected: Vimla.se.