Issues with incoming calls from Telia
Incident Report for Vimla
Resolved
This incident has been resolved
Posted Jan 21, 2022 - 17:33 CET
Investigating
We are currently experiencing issues with incoming calls from Telia. We are investigating the cause.
Posted Jan 21, 2022 - 15:56 CET
This incident affected: Voice.