Issues ordering new subscriptions and login into Mitt Vimla
Incident Report for Vimla
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 15:28 CET
Update
We are continuing to monitor for any further issues.
Posted Dec 12, 2020 - 11:19 CET
Update
We're still working on a permanent fix for this issue.
Posted Dec 11, 2020 - 22:31 CET
Update
A temporary fix has been implemented. We're working on a permanent fix.
Posted Dec 11, 2020 - 20:30 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2020 - 20:06 CET
Investigating
We are currently investigating this issue.
Posted Dec 11, 2020 - 19:10 CET
This incident affected: Mitt Vimla & App.